mpi.inc.php

サマリ麻雀牌列表示プラグイン
リビジョン1.1
対応バージョン1.4.7
投稿者めらまん?
投稿日2007-01-23 (火) 13:44:23

基本情報

mpi プラグインは、PukiWiki 上で麻雀牌列を容易に表示することを目的として作成されたインライン型のプラグインです。

書式

以下のように記述します。

&mpi("麻雀牌表示文字列");

"麻雀牌表示文字列" には、以下で示される文字を並べて記述します。

m     萬子モードに切替え(デフォルト)
p     筒子モードに切替え
s     索子モードに切替え
v     縦表示牌モードに切替え(デフォルト)
h     横表示牌モードに切替え
y     縦横表示牌モード反転

1~9  数牌を表示(事前に m,p,s の指定が必要)
T     東
N     南
S     西
P     北
W     白(White)
H     發
C     中
R     赤五牌(事前に m,p,s の指定が必要)
U     裏牌
_     半角スペース(スペースでも挿入可)
<~>  < と > に挟まれた文字列を表示

使用例 & 入手先

こちら ⇒ http://meraman.dip.jp/index.php?mpi を参照して下さい。

ライセンス

  • 作者への報告なしに自由に使って頂いて結構です。
  • 二次配布もOKです。
  • 改変して使用される場合は、出来ればソースも公開して下さい(強制ではありません)。

更新情報

2007/01/24(水)
XHTML 1.1 not valid なところを修正。
2007/01/23(火)
PukiWiki 用 php プラグインにポーティング
2005/09/28(水)
赤五筒だけでなく、赤五萬、赤五索の表示にも対応。
2005/09/25(日)
fsWiki 用に本プラグインを初公開。

コメント

  • おもしろいですね。さて、XHTML 1.1 not valid です。img タグに alt 属性が指定されていません。<img .. /> のように閉じられていません。 W3C でチェックできます。-- 2007-01-23 (火) 14:38:58
  • ご指摘ありがとうございます。修正したものをアップしておきました。mpi プラグインとは関係ないところでまだ XHTML 1.1 not valid なところは残っていますが・・・。 -- めらまん? 2007-01-24 (水) 03:10:52
    • おつかれさまです。 -- 2007-01-25 (木) 05:06:09


トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2007-06-25 (月) 06:43:48
Site admin: PukiWiki Development Team

PukiWiki 1.5.2+ © 2001-2019 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u7. HTML convert time: 0.216 sec.

OSDN