size_em.inc.php

サマリem指定でフォントサイズを指定するプラグイン
リビジョン0.1.0
対応バージョン1.4.7
投稿者TOBY?
投稿日2009-10-04 (日) 11:13:18

v0.0.6以前(ソース内にバージョン表記ないもの)ではブロック記法にXSSのセキュリティホールが存在するものがあります。お使いの方は、必ずアップデート下さい!! ごめんなさい、ごめんなさい、ごめんなさい…

標準プラグインのsize.inc.phpではpx指定が強制されてしまいますが、このプラグインでは px の代わりに em 指定になります。

&size_em(2.5){test test};

とかすると、font-size:2.5em 指定でフォントサイズを指定できるプラグインです。

バージョン v0.0.6から

#size_em(2.5){{
test
test
}}

などのようにブロック指定もできるようになりました。 (v0.1.0から小数点で指定できるようになりました)

詳細はこちら(作者のwiki):http://tobysoft.net/wiki/index.php?Wiki%2FPukiWiki%2F%BC%AB%BA%EE%A5%D7%A5%E9%A5%B0%A5%A4%A5%F3%2Fsize_em.inc.php

githubリポジトリ: http://github.com/toooooooby/pukiwiki-size_em-plugin/

ダウンロード:

ライセンス: GPLv2 (githubの初期コミットがMIT Licenseになってますが、size.inc.phpのまんま改変だということを思い出したのでGPLに直しました。気にしないで下さい)


トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2009-10-21 (水) 23:46:46
Site admin: PukiWiki Development Team

PukiWiki 1.5.2+ © 2001-2019 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u7. HTML convert time: 0.259 sec.

OSDN