質問箱/2037

カテゴリ
サマリpukiwikiのためのApache,phpの設定
バージョン1.4.2
投稿者femto?
状態完了
投稿日2004-02-16 (MON) 02:43:23

質問

Apache,php,pukiwikiのコンパイル&導入をわかりやすく解説しているWebはないでしょうか?(特にApache)安定版のApache1.3.29,php4.3.4,pukiwiki1.4.2を使いたいと考えています。 OSはNetBSD1.6.1.ですがほぼFreeBSD4.xとおなじです。

回答

  • reimy 2004-02-16 (MON) 13:02:56

    Apacheは標準的なオプションでコンパイルすれば問題ないはず。PHP4は標準的なオプションにマルチバイト関連のオプションを追加してコンパイル。

    • apacheのコンパイルとインストールあたりを参考に。 httpd.conf 中に
      AddType application/x-httpd-php .php
    • PHP4は
      /configure --enable-mbstring --enable-mbregex --enable-zend-multibyte --enable-mbstr-enc-trans --with-zlib --with-gd
      あたりが最低必要なオプションかな。適当に必要なものをこれに加えてコンパイル。mbstringのページも参照。
    • PukiWiki 1.4.2のインストールはPukiWiki1.4のインストールのページ参照。


トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2004-08-21 (土) 01:00:33
Site admin: PukiWiki Development Team

PukiWiki 1.5.2+ © 2001-2019 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u7. HTML convert time: 0.241 sec.

OSDN