質問箱/2502

カテゴリ
サマリWin2000Server+IIS5.0でBasic認証ができない
バージョン1.4.4_php5
投稿者れいん坊
状態完了
投稿日2004-12-23 (木) 20:21:10

質問

れいん坊と申します。

Wikiを触ってからまだ1週間ほどしか経っていない初心者ですので、非常に基本的なことが理解できていないのかもしれませんので、このような場所でお聞きするのは申し訳ないのですが、ご教授をお願いいたします。

下記のように設定し、編集時にBasic認証を行いたいと考えています。 クライアントから編集ボタンを押した際には、「ネットワークパスワードの入力」のダイアログが出るのですが、正しいユーザ/パスワードを入れても認証されず、 3回失敗してエラーページが表示されます。

質問箱/247と同様な症状だと思うのですが、dev:BugTrack/462の内容を理解する力量がない状態です。ぱっと見たところ反映していただいている気もするのですが、正確に判断できませんでしたので、auth.phpの該当すると思われる箇所も記載します。

FAQ、質問箱など探したつもりなのですが、もし同様の内容があるのでしたら、 リンクだけでも結構です。その際はご容赦いただければ幸いです。

サーバー:Windows2000 Server SP4 
     IIS5.0
      ディレクトリセキュリティの設定はAdministrator
      Basic認証は有効に設定
PHP:      5.0.3
Pukiwiki:1.4.4_php5

pukiwikiini.php

$auth_users = array(
	'admin'	=>	'admin',
	'user1'	=>	'user1',
	'user2'	=>	'user2',
);
$auth_method_type = 'pagename';
$edit_auth = 1;
$edit_auth_pages = array(
	'/^.*$/' => 'admin,user1', // 編集制限ページ(正規表現) => 編集許可グループ名
);

auth.php

	// PHP_AUTH* 変数が未定義の場合
	if (!isset($_SERVER['PHP_AUTH_USER'])
		and !isset($_SERVER ['PHP_AUTH_PW'])
		and isset($_SERVER['HTTP_AUTHORIZATION'])
		and preg_match('/^Basic (.*)$/', $_SERVER['HTTP_AUTHORIZATION'],$matches))
	{
		// HTTP_AUTHORIZATION 変数を使用した Basic 認証
		list($_SERVER['PHP_AUTH_USER'], $_SERVER['PHP_AUTH_PW']) = explode(':', base64_decode($matches[1]));
	}
	// ユーザリストに含まれるいずれかのユーザと認証されればOK
	if (!isset($_SERVER['PHP_AUTH_USER'])
		or !in_array($_SERVER['PHP_AUTH_USER'],$user_list)
		or !array_key_exists($_SERVER['PHP_AUTH_USER'],$auth_users)
		or $auth_users[$_SERVER['PHP_AUTH_USER']] != $_SERVER['PHP_AUTH_PW'])

PukiWiki/Install/Windows/XPの設定はしてあるつもりです。 質問箱/2164,質問箱/247,質問箱/2100,質問箱/308,質問箱/2293,質問箱/2117,質問箱/2158あたりは一応読んでみました。

回答



*1 私はこれで2日ほど悩んだことがあります (^^;

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2005-12-22 (木) 09:45:54
Site admin: PukiWiki Development Team

PukiWiki 1.5.3+ © 2001-2020 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u12. HTML convert time: 0.260 sec.

OSDN