質問箱/304

カテゴリ
サマリinit.php on line 37 でエラー
バージョン1.4
投稿者04fa?
状態不明
投稿日2003-11-04 (TUE) 03:27:59

質問

Fatal error: Call to undefined function: array_key_exists()

in /home/***/pukiwiki/init.php on line 37

で、エラーになります。

http://pukiwiki.sourceforge.jp/download/pukiwiki1.4.zip

050246c93e0022b15f4702ae721cbc59 pukiwiki1.4.zip

をダウンロードしました。

Sun Cobalt Linuxにインストールしました。

1.3.5は問題なく動作します。

回答

  • reimy 2003-11-04 (TUE) 06:19:06

    phpのバージョンは? array_key_exists()はPHP 4.1.0から実装されています。

  • mit? 2003-11-04 (TUE) 21:58:50

    私も同様のエラーが出ました pukiwiki1.4.tar.gz 438b21b30654697ac568ce4e299807ad です。 phpは http://nx.eth.jp/hiki.cgi?PHP-i18n-Download の国際化版4.2.3 と 4.2.2 をCGIモードでmakeしたもので試してみましたが同じ症状でした。 ちなみにtelnetでコンソールから php pukiwiki.php を実行すると通常のページが出力されました

  • mit? 2003-11-05 (WED) 00:01:50

    FreeBSD 4.8-RELEASE-p11の鯖で PHP 4.3.0 (2月にどこかから入手した国際化版) では正常に動作しました。

  • mit? 2003-11-05 (WED) 00:05:24

    エラーになったのは Linux 2.2.12-32の鯖(古いです…)で 上記4.3.0のtarボールをmakeしなおしてみましたが、やはり症状は同じでした OSが古すぎ?(^^;


トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2009-07-22 (水) 14:24:13
Site admin: PukiWiki Development Team

PukiWiki 1.5.2+ © 2001-2019 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u1. HTML convert time: 0.167 sec.

OSDN