質問箱/3205

カテゴリ
サマリCPIサーバで動作しない
バージョン1.4.5_1
投稿者むとう?
状態完了
投稿日2005-09-27 (火) 00:09:04

質問

こんばんは。

CPIレンタルサーバで1.4.5_1を動作させようと思っていますが動きません。 どなたかアドバイスをお願い致します。

CPIではCGI版PHPなので「PukiWiki/CGI版PHPで動作させるには」とCPIのPHPを動作させる時の注意事項を参考に、 以下の手順でインストールしました。

1,全てのPHPファイル(全部で108個)の先頭にPHPへのパスを追加

#!/usr/local/bin/php-cgi-4.3.11

2,pukiwikiルートの.htaccessに↓を追加

AddType application/x-httpd-cgi .php

3,PHPファイルの属性を全て705に変更

4,その他のファイル、ディレクトリはPukiWiki/CGI版PHPで動作させるには」に ある様に変更

5,pukiwiki.ini.phpの$scriptを説明通りにURLを設定

上記を行いました。 そして、pukiwiki.phpにアクセスすると、 下記の様に表示されてしまいます。 何が悪いのかアドバイスをお願い致します。

#!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 #!/usr/local/bin/php-cgi-4.3.11 Headers already sent at /usr/home/028/html/pukiwiki/lib/pukiwiki.php line 3.

回答

  • 直接CGIとして叩くファイルにだけ*1#!/usr/local/bin/php-cgi-4.3.11を追加してみるとどうでしょうか? -- 2005-09-27 (火) 00:20:15
  • 質問箱/3201も参考になるはずです。 -- 2005-09-27 (火) 00:21:09
  • pukiwiki.php以外のパスを削除したら動作しました。有り難うございました。 -- むとう? 2005-09-27 (火) 00:38:26


*1 とりあえずpukiwiki.phpだけとか

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2005-09-27 (火) 00:40:28
Site admin: PukiWiki Development Team

PukiWiki 1.5.2+ © 2001-2019 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u7. HTML convert time: 0.229 sec.

OSDN