質問箱/3501

カテゴリ
サマリPukiWikiが動きません
バージョン1.4.7 utf-8
投稿者nanashi?
状態完了
投稿日2006-09-18 (月) 01:14:23

質問

OS:Win2000Pro Server:Apatche 2.0.59 PHP:5.1.6

インストール手順を読んで、pukiwiki.ini.phpのパスワード等を設定し、ブラウザからindex.phpを表示させようとしましたが、真っ白で何も表示されません。 infophp()は動作しているのでPHPやサーバーの設定には問題がないとは思うのですが、Pukiwikiを起動させるのに必要なDLLなどあるのでしょうか? 詳しくそのようなことが書いたページが無かったのでこちらで質問させていただきました。 ご教授お願いいたします。

回答

  • index.phpのerror_reportingをDebug purposeの方にして何かメッセージが出ないか確認してください。 -- 2006-09-18 (月) 01:26:41
  • Warning: require(lib/func.php) [function.require]: failed to open stream: No such file or directory in C:\Program Files\Apache Group\Apache2\htdocs\pw\lib\pukiwiki.php on line 38

Fatal error: require() [function.require]: Failed opening required 'lib/func.php' (include_path='.:/php/includes;C:/PHP/PEAR;C:/Apache Group/Apache2/htdocs/samples;') in C:\Program Files\Apache Group\Apache2\htdocs\pw\lib\pukiwiki.php on line 38 っていうメッセージが出ます。 -- nanashi 2006-09-18 (月) 11:28:43

  • (そのエラーメッセージで検索すれば質問箱/3284に辿り着くと思いますが、今回は逆に混乱しそうなので書きますと)php.iniの「include_path='.:/php/includes;(略)」を「include_path='.;/php/includes;(略)」に直してみてください。 -- 2006-09-18 (月) 12:42:05
  • 単純ミスでした;;申し訳ないです。レスしていただきありがとう御座いました。 -- nanashi? 2006-09-18 (月) 13:10:11

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2015-04-24 (金) 09:02:39
Site admin: PukiWiki Development Team

PukiWiki 1.5.2+ © 2001-2019 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u7. HTML convert time: 0.251 sec.

OSDN