質問箱/4419

カテゴリ
サマリzoome動画の貼り付け
バージョン1.4.7
投稿者動画部雑用?
状態質問
投稿日2009-01-26 (月) 01:03:15

質問

zoomeの動画をpukiwiki内に貼り付けようと思い phpファイルをDL、ftpで/pluginにアップロードして

#zoome(ID)をいれても 文字のまま表示されてしまいます。 これはプラグインの導入そのものができていないのでしょうか? それとも他の原因でしょうか?

回答

  • 自作プラグイン/zoome.inc.php ですよね。正しい場所にアップされてるなら、入力した文字そのままで表示されることはないはずですが・・・ -- 2009-01-26 (月) 12:09:03
  • そのページの下にあるものをDL⇒解凍して/pukiwiki/pluginの中にうpしました。名前がzoome[1].inc.phpですると質問で書いたように文字のまま表示。[1]を消して再度うpしなおすと今度は真っ白なページに・・・。 -- 動画部雑用? 2009-01-26 (月) 18:39:30
  • 内部では、プラグイン名.inc.php でファイルを探しますから、zoome.inc.php でうpが正解。画面が真っ白になるのは、PHP エラーが発生しても表示しない設定だからでは? -- 2009-01-26 (月) 22:20:23
  • パーミッションは適切に設定済みかな?というのが気になったりする。644とか、誰でも「読める」設定であれば問題ないと思うけど。(戯言~、開いてみたところ、半角英数字のみだから問題ないとは思うけど、このファイルはUTF-8だね。Wikiは、どっちだろうというのも気になる。試しにEUCで保存しなおしてみるのも有りかなぁ?) -- 2009-01-26 (月) 22:49:59
  • パーミッション?644?wikiはどっち?EUC?ごめんあさい、初心者なもので意味があまり・・・ どのあたりを参照すればいいでしょうか? -- 動画部雑用? 2009-01-27 (火) 04:28:01
  • 初心者ならまずはPukiWiki/Install/インストール方法を参照して、まっさらな状態で動くようにしてからのほうがいいと思うよ。 -- 2009-01-27 (火) 09:18:15
  • @cmsのインストーラーで設置したのですが、それがダメなんでしょうか?「配置する前に」までの部分は特に問題があるようには思えなかったのですが -- 動画部雑用? 2009-01-27 (火) 12:17:34
  • おそらく問題は多分無いけれど、知識がない状態より問題の切り分けができるようになるかと。パーミッションとか設置しているpukiwikiのエンコードとか。 -- 2009-01-27 (火) 13:13:33
  • EUC-JP とUTF-8 のどちらでWiki を設置したのかは、かなり重要です。それにあわせて、プラグインなども導入する必要がありますので。(文字化けなどの不都合につながる)
    設置しなおすのが面倒なら、ヘルプ という名前のページを作ってみてください。URL が、/?%A5%D8%A5%EB%A5%D7 になったらEUC-JP 版、/?%E3%83%98%E3%83%AB%E3%83%97 になったらUTF-8 版です。 -- 2009-01-27 (火) 13:19:16
    • それもですが、このQ&A のA1 を参考にPHP のエラーメッセージが表示されるようにしてみてください。どのようなエラーが出ているかで、対処法が違ってきますので、そのメッセージをこちらに書き込んでください。でないと、的外れな回答をしてしまうかもしれないので。 -- 2009-01-27 (火) 13:19:16
  • エラーメッセを表示するようにしたところNotice: Only variable references should be returned by reference in /pukiwiki/lib/convert_html.php on line 145 と102が書いた文字列がずらーとなりました。 -- 動画部雑用? 2009-01-27 (火) 15:32:01
    • ↑トップページが上記のように。ヘルプページを作ると後者のURLだったのでUTF-8版と思います -- 動画部雑用? 2009-01-27 (火) 15:34:36
  • そのエラーは、dev:BugTrack2/146 の話題の分ですね。・・・じゃなくって、zoome プラグインを使った時にエラーがでるのか、が今回の問題点なのでは? -- 2009-01-27 (火) 17:37:00
  • topページに表示されてzoomeプラグインを使ったページの作成が出来ないのですが・・・ -- 動画部雑用? 2009-01-27 (火) 19:07:15
  • ページをあらかじめ作っておいてから直リンクでいってみたら Notice: Only variable references should be returned by reference in /pukiwiki/lib/convert_html.php on line 102 とでました。 -- 動画部雑用? 2009-01-27 (火) 19:54:23
  • dev:BugTrack2/146 を見て、まずはそのNotice エラーを消す。それからも、エラーが出なくなるまで修正をしていく。最後に、zoome プラグインからのエラーを確認して修正する。 -- 2009-01-28 (水) 22:02:15
  • わかる範囲でやってみたのですが今度は別のエラーが。Parse error: syntax error, unexpected T_RETURN in /pukiwiki/lib/convert_html.php on line 100 これはconvert_html.phpをワードで開いて背景が青の部分をコピーし保存、うpしたのですが。毎度毎度お手数をおかけしてすみません -- 動画部雑用? 2009-01-29 (木) 01:23:15
  • 差分ファイルをそのまま貼り付けても、動きませんよ。
    そのページに載っている差分ファイルの形式では、- で始まる行と同じものを対象ファイルから消して、+ で始まる行を(もちろん、頭の+ を除いて)対象ファイルに追記する必要があります。
    また古い記述の場合、過去のバージョンを基準とした表記になっていて、現在のバージョンとは書き換える場所や内容が違う場合があるので、注意が必要です。 -- 2009-01-29 (木) 21:00:44
  • 差分ファイルの-を消して+を追記し、#zoome()のページを見ると何も表示されなくなりました。試しにzoome.inc.phpを消してページを見てみるとHeaders already sent at /pukiwiki/lib/convert_html.php line 1004のエラーが表示されました。これはconvert_html.phpがきちんと修正されていないのでしょうか?またワードで編集したのがまずかったのでしょうか? -- 動画部雑用? 2009-01-29 (木) 23:18:21
  • せめてこのサイトだけでもいいから、検索してから質問してください。少なくてもQ&A/インストール#jae2cf51 が、Headers already sent の検索で引っかかるはずです。
    「ワードで~」は文字コードが(UTF-8 版なので)UTF-8 、改行コードがLF で出力できているのなら問題はないのですが、それができないのならQ&A/インストール#mb87f9af 記載のエディタを使ったほうがいいでしょう。
    修正を失敗したのか、それとも改行コードのせいなのかは、この情報だけでは判別できないです。(両方の可能性も) -- 2009-01-30 (金) 02:34:59
  • 最後の数字だけで検索してました。頭が回らずすみませんです。 -- 動画部雑用? 2009-01-30 (金) 17:53:39
    • エラーメッセージはだいたい、「エラーの区分 : エラーの種類(+詳細や解決のヒント) エラーが発生したファイルパス 発生した行数」という構成です。バージョン違いや改造などの要因で、エラーが発生する行は違ってくるので、検索するならエラーの種類やファイル名で調べたほうがいいですよ。 -- 2009-01-30 (金) 18:21:47
  • 連投すみません。少し状況に変化がありました。zoomeのプラグインファイルを解凍し、それを更に解凍したものをプラグインの中に入れると画面の埋め込みは出来たのですが、別枠でスクリプトエラーと表示がでました。ライン:53 文字:3 エラー:オブジェクトがありません コード0 URL http://~index.php?test testというページでzoomeの埋め込みを行いました。 -- 動画部雑用? 2009-01-30 (金) 18:01:58
  • 配布元で動いているPukiWiki Plus! 特有のセキュリティでつまずいてましたか・・・*1
    で、出力されたHTML ソースのライン:53 に何があるのかや、その前後の文章が開示されていないため、どこに問題があるのかを判断できません。
    プラグインの設置そのものはうまくいっているようですので、あとはそちらの環境に合わせた設定や修正をするぐらいでしょう。
    プラグインの指定方法が悪いのか、それともバグなのか、といったあたりの情報は、配布元 でコメントして尋ねた方が、早く解決するかもしれません。
    どちらで質問を続けるにしろ、情報がないと判断できません(最低限の情報ではそれなり~な対応しかできない)ので、それはお願いしますよ。 -- 2009-01-30 (金) 21:30:58
  • 稚拙な質問にも関わらず回答していただき本当にありがとうございました。一度配布元でたずねたいと思います。大変なお手数をおかけいたしてすみませんでした。 -- 動画部雑用? 2009-01-30 (金) 21:51:16


*1 セキュリティ対策として、添付ファイルを圧縮して保存する機能があるのですが、特定の環境では2重圧縮を回避する機能が働かないんですよね

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2009-01-30 (金) 21:51:16
Site admin: PukiWiki Development Team

PukiWiki 1.5.2+ © 2001-2019 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u7. HTML convert time: 0.256 sec.

OSDN