質問箱/4533

カテゴリ
サマリ特定の文字列を入力すると、Forbidden が表示される
バージョン1.4.7
投稿者est?
状態完了
投稿日2009-12-02 (水) 18:23:04

質問

やっとwikiを立てられたのはいいのですが、 wikiの編集時に -が一つだと普通に入力できるのですが (-aaa で・aaaと表示される。)、 -を二つ以上並べると

Forbidden
The server refuse to browse the page.
The URL or value may not be correct. Please confirm the value.

となってしまいます。 (--、---や水平線が使えない) これはどこか設定を間違えてしまったのでしょうか? 他の入力自体は特に問題が無い様なのですが。

回答

  • サーバやPHP のエラーログは確認できますか? -- 2009-12-03 (木) 01:58:16
  • すみません、確認方法自体あまりよくわかっていません。ちなみにレンタルサーバはさくらネットの方を借りています。 -- 2009-12-03 (木) 19:58:50
  • Forbidden って事は、HTTP 403 エラー?レンタルサーバならサポートに連絡すれば、エラーログを見せてくれるかもしれません。 -- 2009-12-04 (金) 11:24:44
  • エラーログを貰ってみたのですが、上の状況に関係している物はなさそうでした。(favicon云々のみ) -- 2009-12-08 (火) 21:36:24
  • ファイアウォールで切られているとかではないですよね?
    もし容量に余裕があるのならば、変更を一切加えていないものを別にディレクトリに新しく立てて、比較してみては?もし素の状態で問題がないのなら、変更を加えた部分のどこかに問題があるということが判りますし、段階的に変更を適用していけば原因を特定できるかもしれません。逆に素の状態でも異常があるとなると、サーバかPHP の設定に問題がある(PukiWiki 向けの設定ではない)ということになります。 -- 2009-12-09 (水) 01:32:02
  • すみません。色々調べてみたらWebアプリケーションファイアウォールで引っかかっている事が解りました。どうもありがとうございました。 -- 2009-12-12 (土) 01:45:56

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2009-12-26 (土) 13:54:37
Site admin: PukiWiki Development Team

PukiWiki 1.5.2+ © 2001-2019 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u7. HTML convert time: 0.206 sec.

OSDN