質問箱/5122

カテゴリエラー・トラブル
サマリサーバー再起動で500エラー
バージョン1.4.6以降
投稿者moly?
状態完了
投稿日2013-01-19 (土) 18:45:31

質問

はじめまして. 自分ではどうにもできない状態でして,皆さんの知恵をお貸しいただければと思います.

2つのサーバ(さくらVPS)でpukiwikiを運営してましたが,ほぼ同時期にサーバの再起動が入り,その後にpukiwikiにアクセスするとどちらも500エラーとなってしまいます. 2つのサーバの共通点はこの再起動があったという点のみで,それぞれサーバは次のようになります. ※追記)どちらもPHPのアップデートがありました.

  • CentOS 5.8
    • Webサーバ: Apache 2.2.3
    • PHP: 5.4.10
    • Pukiwiki: 1.4.6以降
    • Wordpress動作確認済
  • CentOS 6.3
    • Webサーバ: Nginx 1.2.6
    • PHP: 5.4.11
    • php-fpm: 5.4.11
    • Pukiwiki 1.4.6以降
    • Wordpress動作確認済

Pukiwikiのバージョンはadminpassの部分で判断しました.

どちらのサーバのWebサーバのエラーログには何も出力されておらず,6.3のphp-fpmのエラーログにも何も出力されていません. エラーログが何もないので,お手上げ状態です….

また,両サーバとも最新のpukiwikiをインストールしてみましたが,500エラーとなりました.

よろしくお願いいたします.

回答

  • アップデート前のPHPが5.3.xだったとかなら、確実にPHPが5.4.xになったのが原因。dev:BugTrack2/349質問箱/5098質問箱/5119 -- 2013-01-19 (土) 20:47:34
  • hex2binの編集で無事に動作しました。大変参考になりました。どうもありがとうございました。 -- moly? 2013-01-19 (土) 22:04:29


トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2013-01-19 (土) 22:04:37
Site admin: PukiWiki Development Team

PukiWiki 1.5.2+ © 2001-2019 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u2. HTML convert time: 0.522 sec.

OSDN