質問箱/5359

カテゴリ動作環境
サマリ表組みの罫線の色
バージョン1.5.2
投稿者のん?
状態質問
投稿日2019-12-31 (火) 09:39:55

質問

ロリポップでPHP 7.3.10 のバージョンアップに伴い、pukiwikiを1.4.7→1.5.2にバージョンアップしたところ

表組みの罫線の色がなくなり白くなってしまいました。

一応、質問箱にある該当するかも知れない対応措置は試しましたが現象が変わらないので質問させて頂きました。

どこを修正すればいいのでしょうか?

回答

  • Tool/CSSDiff -- t? 2019-12-31 (火) 14:06:34
  • ご回答ありがとうございます。 -- のん? 2019-12-31 (火) 21:45:03
  • 私の理解が悪いのでしょうか? bk -- のん? 2019-12-31 (火) 21:45:56
  • >質問箱にある該当するかも知れない対応措置は試しました
    どこに書いてある何を参考にしてどうしたのかを具体的に書いた方がいいのではないでしょうか。 -- D? 2019-12-31 (火) 21:58:50
  • 「1.4.7→1.5.2」へのバージョンアップを、バッチを使って段階的に行ったのか、別の手段をとったのかが第三者にはわかりません。
    また、どこかで配布されているスキンを利用していたのかどうかもどんなプラグインを別途入れていたのかもここに書かれていないので第三者にはわかりません。
    1.5.1⇒1.5.2になったときにcss.phpから.cssに変更されています。そのほか各種変更など確認されているでしょうか -- D? 2019-12-31 (火) 22:15:51
  • 確かにそうですね… 申し訳ありませんでした。 「1.4.7→1.5.2」へのバージョンアップはFFFTPで各フォルダ配下を削除して1.5.2のプログラムをコピーしました。 他のスキン、プラグインも入れてません。変更した箇所もありません。オリジナル構成のままです。 また、質問箱にある該当するかも知れない対応措置は試しましたが、変化がないのですべてバックアップを上書きして元に戻してますので 現状はオリジナルのままです。 ツールにて差分をpukiwiki.cssに反映したのですが変化なしです。 -- のん? 2019-12-31 (火) 22:57:10
  • 確かにそうですね… 申し訳ありませんでした。 「1.4.7→1.5.2」へのバージョンアップはFFFTPで各フォルダ配下を削除して1.5.2のプログラムをコピーしました。 他のスキン、プラグインも入れてません。変更した箇所もありません。オリジナル構成のままです。 また、質問箱にある該当するかも知れない対応措置は試しましたが、変化がないのですべてバックアップを上書きして元に戻してますので 現状はオリジナルのままです。 ツールにて差分をpukiwiki.cssに反映したのですが変化なしです。 -- のん? 2019-12-31 (火) 23:03:43
  • 質問箱/2251 と基本は同じです。場所がskin/pukiwiki.cssに変わっているだけです。 -- D? 2020-01-01 (水) 10:30:59
    • .style_table の background-colorに何が指定されているのかを確認してください
    • サイトのソースを見てcssが読み込まれているのかどうかを確認してください
    • linksでページ間のキャッシュを更新してどうなるのかを確認してください
    • ブラウザのキャッシュを削除してからアクセスする、あるいは違うブラウザでアクセスするとどうなるのかを確認してください
      • 1.5.2からはHTML5になっているので、対応していないブラウザではきちんと動作しないと思います
  • お正月にも関わらず御解答頂き誠にありがとうございます。 質問箱/2251は既に試しました。が再度試しましたが変化なしです。質問箱に該当するかも知れない対応は 表、枠、線、色に該当するものはすべて試しましたが変化がなかったので質問した次第です。 で、HTML5に関して当方のブラウザはFireFox 71.0、IE11、Edge44.18362.449.0、EdgeHTML18.18363なので問題はないと思いますが、どのブラウザでも枠線は白になります。 ついでにスマホではAQUOS アンドロイド 8.0.0 でスマホで見ても枠線は白になります。 サイトのソースでskin/pukiwiki.cssが読み込まれる事を確認しております。 .style_table の background-colorは#ccd5ddとなっております。 pukiwiki1.4.7で作成したページデータを1.5.2の上に乗せて表示させようとしてるだけなんですが… 他の色や表組背景色とか文字色とかはすべて表示していますが、表枠の線だけが出なくて白なんです。 ちなみに自作プラグstyle_table.diffのパッチを実施すると何も表示されなくなり画面が真っ白になります。 -- のん? 2020-01-02 (木) 01:39:37
  • >質問箱/2251は既に試しました
    これは「質問箱にある該当するかも知れない対応措置は試しました」からは第三者には読み取れません。なにを読んで何をやったのかが第三者にはわからないので、具体的に書かないと結局既にやったことを蒸し返されることになります。
    サーバーの空き領域があるのであれば、そちらにpukiwiki1.5.2をそのままインストールしてみてください。1.4.7からの引継ぎが一切ない状態でそのサーバーで表の枠線が表示されるのであれば、1.4.7から引き継いだものの中に原因があるということになります。 -- D? 2020-01-02 (木) 10:08:21
    • 『自作プラグstyle_table.diffのパッチ』というのは質問箱/3510にあるリンク先のものだと思いますが
      リンク先の説明をきちんと読んでいるんでしょうか
      >あらかじめ、skin/pukiwiki.css.phpに指定するスタイルを定義してください
      pukiwiki1.5.2ではskin/pukiwiki.css.phpがなくなってskin/pukiwiki.cssになっているのでこれは動かないです。
      解決を急ぐあまり、いろんなところに書いてある説明や注意書きをきちんと読んでいないので、さらに問題が悪化している気がするんですよね。
  • >pukiwiki1.5.2をそのままインストールしてみてください。1.4.7からの引継ぎが一切ない状態 サーバーの別領域にpukiwiki1.5.2をFFFTPにてそのままインストールしました。 まったく1.4.7からの引継ぎが一切ない状態です。インストールして一発目に新規ページにて表組みを作成しましたが 枠線に色がなく白い線の状態となっております。 -- のん? 2020-01-02 (木) 21:20:15
  • そもそもこの質問ページの上部にある表の枠線は表示されているのでしょうか -- D? 2020-01-03 (金) 11:16:00
    • あとできそうなのはダウンロードしたpukiwiki1.5.2(UTF-8なのかEUC-JPなのか知りませんけど)が壊れているかもしれないので、新規に別途ダウンロードして解凍後に、サーバーに上げてみる
      ロリポップのPHP7.3.*はモジュール版とCGI版があるようなので、現在どちらを使っているのかわかりませんが、切り替えてみる
      ロリポップ側に質問してみる
      ぐらいじゃないでしょうか
  • この質問ページの上部にある表の枠線はちゃんと表示されています。 ダウンロードしたpukiwiki1.5.2はUTF-8です。(サーバーがUTF-8推奨になったので) 新規に別途ダウンロードして解凍したものを入れました。 ロリポップのPHP7.3.*はモジュール版です。CGI版は不可のようです。 -- のん? 2020-01-03 (金) 12:59:36
  • ロリポップのPHP7.3.*のCGI版を選択してても昨年12月に強制的にモジュール版に切り替わる。との事でしたので モジュール版に切り替えてからpukiwiki1.5.2をインストールしました。 -- のん? 2020-01-03 (金) 13:08:55
  • 今現在サーバーにあるものが壊れている可能性があるので新規にもう1回やり直してみる必要があるかもしれないと書いたんですけど。
    >ダウンロードしたpukiwiki1.5.2はUTF-8
    過去に使っていたものがEUC-JPであったのなら、そのテキストエディタをそのままUTF-8版で使っても文字化けします。今回の不具合(?)もそれに関連するのかもしれません(pukiwikiの上位ディレクトリに何も置かれていない&サーバー側での何らかの制限に関係していないとしてですが)。
    参考:質問箱/4242 -- D? 2020-01-04 (土) 09:18:10
    • あと、linksでページ間のキャッシュを更新してどうなるのかを確認してください
  • >新規にもう1回やり直してみる必要があるかも… これはサーバーに新規でフォルダを作成して、再度ダウンロードしたpukiwiki1.5.2 UTF-8 をインストールしました。 で、新たな発見ですが… PCを再起動してブラウザを開き今回インストールしたオリジナル状態のpukiwikiを表示して表組みをしたところ罫線の色が出ました。 で、そのまま問題のある領域のpukiwikiを表示して表組みをしたところ罫線の色は出ませんでした。で、そのままオリジナル状態のpukiwikiを表示して表組みをしたところ罫線の色は出ませんでした。 罫線が出ない状態でPCを再起動してオリジナル状態のpukiwikiを表示して表組みをしても色が出ないので、これはフォーム(CSS)?の情報がメモリ上? PC上?のキャッシュか何か、どこかに保存されるように思えるんですが… 明らかにこちらのPCの環境問題に起因しているようです。申し訳ございませんでした。こういう質問してもいいかわかりませんがフォーム(CSS)?の情報が保存されるのはPCの設定でしょうか?ブラウザの設定でしょうか? -- のん? 2020-01-04 (土) 15:18:46


トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2020-01-04 (土) 15:18:46
Site admin: PukiWiki Development Team

PukiWiki 1.5.2+ © 2001-2019 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u8. HTML convert time: 0.272 sec.

OSDN