PukiWiki 1.5.0

  • PukiWiki 1.5.0: 2014/07/19 リリース & 告知

PHP5.4 及び PHP5.5 に対応しました。


ダウンロード

それぞれ、ファイル名をクリックするとダウンロードが始まります。

ファイル一覧・MD5ハッシュなど

フルセット (PHP4.1.0以降 / PHP5以降 両対応)

エンコードファイルサイズ
UTF-8pukiwiki-1_5_0_utf8.zip403.5 KBおすすめ
EUC-JPpukiwiki-1_5_0_eucjp.zip394.5 KB

UTF-8版を推奨します。新規利用の際はUTF-8版をダウンロードしてお使いください。既設のPukiWikiサイトがEUC-JPで構築されている場合にはEUC-JP版を利用できます。

  • UTF-8版: UTF-8向けに基本設定、ならびに初期データを変換したもの
    • WebブラウザにUTF-8を出力します
    • テキストデータはすべてUTF-8で保存されます
    • Unicode文字を保存するため、EUC-JPでは扱えない文字を利用できるようになります。また、Unicodeによる多言語環境を実現できます
    • 設定をUTF-8で記述する必要があります
  • EUC-JP版: 従来のPukiWikiと同一
    • WebブラウザにEUC-JPを出力します
    • テキストデータは全てEUC-JPで保存されます
    • 設定をEUC-JPで記述する必要があります

1.4.7(notb)から1.5.0へのアップデートパッチ

エンコードファイルサイズ
UTF-8update_pukiwiki_147to150_utf8.patch107.9 KB
EUC-JPupdate_pukiwiki_147to150_eucjp.patch107.1 KB

アップデート方法は PukiWiki/Install/Update/1.5.0 を参照してください。


Thanks to

  • dev:BugTrack2/349 にて PHP5.4対応情報をまとめてくださったよっちいさん
  • バグ報告をしてくださった皆様
  • バグ修正をしてくださった皆様
  • pukiwiki-official や dev サイトがより使い易くなる様に、相互にリンクを張ったりコメントを加えてくださる皆様
  • 自分に迷惑をかけることをいとわぬ冒険者
  • pukiwiki-official や devサイトや WikiWikiWeb の将来について模索しているWeb委員の皆様
  • EclipseプラットフォームおよびPHPプラグインの開発や日本語化に携わった皆様 (いまや、これ無しには…)
  • Zend Studio (まずいコードの探索 / 言葉通りの「デバッグ」 / 分析に大活躍)
  • そして…PukiWikiを利用してくださっている皆様

インストール / アップデート

パッケージ付属文書をご覧下さい。

以下の文書は詳しいですが、少し古くなっています。


トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2015-01-03 (土) 07:43:57
Site admin: PukiWiki Development Team

PukiWiki 1.5.2+ © 2001-2019 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u6. HTML convert time: 0.204 sec.

OSDN