#norelated
* PukiWiki 1.5.0 [#m582de7d]
- PukiWiki 1.5.0: 2014/07/19 リリース & 告知

PHP 5.4 及び PHP 5.5 に対応しました。
PHP5.4 及び PHP5.5 に対応しました。


--------------------------------
** ダウンロード [#p2f62cc6]

それぞれファイル名をクリックするとミラーサーバー一覧が表示されますので、お近くのミラーサーバーからダウンロードして下さい
それぞれ、ファイル名をクリックするとダウンロードが始まります。


[[ファイル一覧・MD5ハッシュなど:http://sourceforge.jp/projects/pukiwiki/files/]]

*** フルセット (PHP4.1.0以降 / PHP5以降 両対応) [#bc9af164]
|エンコード|ファイル                |  サイズ  |h
|UTF-8|[[pukiwiki-1_5_0_utf8.zip>http://sourceforge.jp/projects/pukiwiki/downloads/61634/pukiwiki-1_5_0_utf8.zip/]]|400.6 KB|
|EUC-JP|[[pukiwiki-1_5_0_eucjp.zip>http://sourceforge.jp/projects/pukiwiki/downloads/61634/pukiwiki-1_5_0_eucjp.zip/]]|388 KB|
|エンコード|ファイル                |  サイズ  ||h
|UTF-8|[[pukiwiki-1_5_0_utf8.zip>http://sourceforge.jp/projects/pukiwiki/downloads/61634/pukiwiki-1_5_0_utf8.zip/]]|403.5 KB|おすすめ|
|EUC-JP|[[pukiwiki-1_5_0_eucjp.zip>http://sourceforge.jp/projects/pukiwiki/downloads/61634/pukiwiki-1_5_0_eucjp.zip/]]|394.5 KB||

UTF-8版を推奨します。新規利用の際はUTF-8版をダウンロードしてお使いください。既設のPukiWikiサイトがEUC-JPで構築されている場合にはEUC-JP版を利用できます。

- UTF-8版: UTF-8向けに基本設定、ならびに初期データを変換したもの
-- Unicode文字を保存する事ができるため、EUC-JPでは扱えない特殊な文字を((Unicodeで表現されている物については))利用できるようになります。また、Unicodeによる多言語環境を実現できます。
-- それぞれの処理に UTF-8エンコーディング を使用します (UTF-8を処理できるWebブラウザ、およびメンテナンス環境が必要です)
-- EUC-JP版に比べ、マルチバイト文字を保存するためのスペースがより多く必要になります (URLが長くなり、保存されるファイル名が長くなり、ファイルサイズが増加します)
-- WebブラウザにUTF-8を出力します
-- テキストデータはすべてUTF-8で保存されます
-- Unicode文字を保存するため、EUC-JPでは扱えない文字を利用できるようになります。また、Unicodeによる多言語環境を実現できます
-- 設定をUTF-8で記述する必要があります


- EUC-JP版: 従来のPukiWikiと同一
-- WebブラウザにEUC-JPを出力します
-- テキストデータは全てEUC-JPで保存されます
-- テキストデータのファイル名はEUC-JPベースの文字列から生成されます
-- 設定をEUC-JPで記述する必要があります

*** 1.4.7(notb)から1.5.0へのアップデートパッチ [#za58ab70]
|エンコード|ファイル                |  サイズ  |h
|UTF-8|[[update_pukiwiki_147to150_utf8.patch>http://sourceforge.jp/projects/pukiwiki/downloads/61634/update_pukiwiki_147to150_utf8.patch/]]|107.9 KB|
|EUC-JP|[[update_pukiwiki_147to150_eucjp.patch>http://sourceforge.jp/projects/pukiwiki/downloads/61634/update_pukiwiki_147to150_eucjp.patch/]]|107.1 KB|


アップデート方法は [[PukiWiki/Install/Update/1.5.0]] を参照してください。


--------------------------------
** Thanks to [#q9f172bd]
- [[dev:BugTrack2/349]] にて PHP5.4対応情報をまとめてくださった[[よっちい>dev:よっちい]]さん
- バグ報告をしてくださった皆様
- バグ修正をしてくださった皆様
- pukiwiki-official や dev サイトがより使い易くなる様に、相互にリンクを張ったりコメントを加えてくださる皆様
- 自分に迷惑をかけることをいとわぬ[[冒険者]]達
- 自分に迷惑をかけることをいとわぬ[[冒険者>dev:冒険者]]達
- pukiwiki-official や devサイトや WikiWikiWeb の将来について模索している[[Web委員]]の皆様
- [[Eclipseプラットフォーム>http://www.eclipse.org/]]および[[PHPプラグイン>http://trustudio.org/]]の開発や日本語化に携わった皆様 (いまや、これ無しには…)
- [[Zend Studio>http://www.zend.co.jp/products/studio/]] (まずいコードの探索 / 言葉通りの「デバッグ」 / 分析に大活躍)
- そして…PukiWikiを利用してくださっている皆様


--------------------------------
** インストール / アップグレード [#id8414f7]
** インストール / アップデート [#id8414f7]

パッケージ付属文書をご覧下さい。
- [[README.txt>http://sourceforge.jp/projects/pukiwiki/scm/git/pukiwiki/blobs/master/README.txt]] (概要)
- [[INSTALL.txt>http://sourceforge.jp/projects/pukiwiki/scm/git/pukiwiki/blobs/master/INSTALL.txt]] (セットアップ~バックアップまで)
- [[UPDATING.txt>http://sourceforge.jp/projects/pukiwiki/scm/git/pukiwiki/blobs/master/UPDATING.txt]] (互換性に関する記述)

以下の文書は詳しいですが、少し古くなっています。

- [[PukiWiki/インストール/1.4系列]]
-- [[PukiWiki/インストール/1.4系列#vdfcb3b6]] (1.3.x系列からの移行方法)


トップ   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Site admin: PukiWiki Development Team

PukiWiki 1.5.3+ © 2001-2020 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u12. HTML convert time: 0.132 sec.

OSDN