**[[質問箱/171]] [#t30c635b]
|RIGHT:70|LEFT:410|c
|~サマリ|Parse error|
|~バージョン|1.3.5|
|~投稿者|[[jkl]]|
|~状態|不明|
|~投稿日|&new{2003-06-12 (THU) 19:55:19};|
***質問 [#p072f53e]
~pukiwikiをダウンロードし、ローカル側で解凍、インストール手順にあった管理者名の変更や、ホームページの変更を行い、ftpでサーバに転送したのですが、pukiwiki.phpを表示させると以下のようなエラーが出ます。
 Parse error: parse error, expecting `T_CONSTANT_ENCAPSED_STRING' in plugin.php on line 25
~パーミッションやファイルの転送モードは何度も確認したのですが、エラーが消えません。ちなみにplugin.phpの25行目は
      require_once(PLUGIN_DIR.$name.".inc.php");
こんなのでした。pukiwikiは1.3.5です。

***回答 [#b1bc0bd6]
-[[名無しさん]] &new{2003-06-13 (FRI) 23:48:10};
~PHPのバージョンはいくつですか?
~require_once()とPHPのバージョンに関して興味深いやり取りがあったので引用しておきます。
--http://php.weblogs.com/discuss/msgReader$249
>
>>>In adodb 0.70 you changed the 'include'-statements in adodb_ado_access.inc.php and adodb_ado_mssql.inc.php to 'require_once'.~
>>>gives an error (at least in NT): Parse error: parse error, expecting `T_CONSTANT_ENCAPSED_STRING' in d:erz02_testassetsphpadodbadodb-ado_mssql.inc.php on line 16
<
--http://php.weblogs.com/discuss/msgReader$250
>
&gt;>>it works fine with PHP 4.03pl1. Perhaps you are using an older version of PHP?
<
--http://php.weblogs.com/discuss/msgReader$252
>
&gt;>>You're right, I use a 4.02 on this machine.
<

#comment


トップ   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Site admin: PukiWiki Development Team

PukiWiki 1.5.3+ © 2001-2020 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u12. HTML convert time: 0.045 sec.

OSDN