**PukiWiki 1.4が動くPHPのバージョンは? [#y8fa3469]
-種別 : 動作環境
-バージョン : 1.4系
***質問 [#g7ffcb60]
~PukiWikiが動くPHPのバージョンは?
***回答 [#h35ba058]
4.1.2 以降が確実です。それより前のバージョンでは、グローバル変数周りやmb_string関係、version_compare()((PHP 4.1.0 以降に標準搭載)) などで問題が起きることがあります。

*** 関連 [#g6513e90]
- [[dev:BugTrack/529]] 「ChaSen, KAKASI による、ページ名の読みの取得機能」が利用できない (Debian woody限定)

***補足 [#j72da57e]

- メンテナンス(セキュリティアップデート)が行われていないPHPはインターネット上で使わない様にしましょう。
-- Debian GNU/Linux 3.0 (Woody) では、PHP 4.1.2 をベースに必要最低限のメンテナンスが[[行われています>http://www.debian.org/security/]]((完全かどうかの保証はできません))。メンテナンス期限は[[次の安定版(stable)が出てから一年、ないしそれ以内>http://www.debian.org/security/faq#lifespan]]です。
-- Red Hat Linux 9 に搭載されていた PHP 4.2.2 は、[[Fedora Legacy>http://fedoralegacy.org/]] プロジェクトにて必要最低限のメンテナンスが[[行われています>http://fedoralegacy.org/updates/RH9/]]((完全かどうかの保証はできません))。(Red Hat 7.2および8のサポートは既に打ち切られています)

- version_compare() を呼んでいる部分は、内容に応じた固定値に書き直すことで回避できるとは思いますが、古いPHP向けに、PEAR パッケージの PHP_Compat に移植されているものがあるようですので、こちらを試すことができるかもしれません。
-- http://pear.php.net/package/PHP_Compat
-- PHP_Compat に 登録されている関数および定数の一覧: http://pear.php.net/manual/ja/package.php.php-compat.components.php


トップ   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Site admin: PukiWiki Development Team

PukiWiki 1.5.3+ © 2001-2020 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u12. HTML convert time: 0.058 sec.

OSDN