#author("2018-03-09T00:47:59+09:00;2007-11-21T12:16:06+09:00","","")
**[[質問箱/217]] [#xbd767f4]
|RIGHT:70|LEFT:410|c
|~カテゴリ||
|~サマリ|#paintが動かない|
|~バージョン|1.4|
|~投稿者|[[sha]]|
|~状態|完了|
|~投稿日|&new{2003-07-17 (THU) 22:04:51};|
***質問 [#f6a337ea]
1.4標準プラグインの[[paintの説明>PukiWiki/プラグイン/1.4#v8fdd864]]に従って、BBSPainter.jarを入手し、pukiwiki.ini.phpと同じディレクトリに放り込んだのですが、うまく動作しません。どうしたらよろしいでしょうか?

【症状】#paintと書いておくと、80x60と[paint]のボタンが表示されます。[paint]を押すと、別のページが表示され、Javaをロードしているようなのですが、ロードが永遠と続いて全く反応がありません。ブラウザはIE6.0SP1です。

【環境】動作しないことが確認できた環境
||LEFT:|c
|OS|>|Windows XP Home Edition SP1|
|ブラウザ|IE6.0SP1, Netscape7.02|Netscape7.1|
|VM| SunのJava(J2RE,SE v1.4.0_03、v1.4.1、v1.4.2)|J2RE,SE v1.4.1_02|


***回答 [#q40d6ce7]
-[[reimy]] &new{2003-07-18 (FRI) 00:12:38};
~もう少し環境を書いてください。IE6.0SP1ということですが、JavaのRuntimeはSunのJavaでしょうか? それともMS VMでしょうか?
-[[sha]] &new{2003-07-18 (FRI) 00:27:34};
~インターネットのプロパティの「詳細」タブによりますと、Java(Sun)で「<applet>にJava 2 v1.4.0_03を使用する」にチェックが入っております。タスクバーには、コーヒーマークのアイコンが見えます。また、今ブラウザを動かしているOSは、Windows XP Home Edition SP1です。あとどんな情報が分かればよいでしょうか?そういえば、sun.awt.windows.defaultのロードで止まっているように見えます。
-[[reimy]] &new{2003-07-18 (FRI) 01:00:00};
~Javaの初期化に失敗しているようですねぇ。Java 2 Ver1.4.1のころに同じような症状になったことがあります。Ver1.4.2にしてからはその症状にお目にかかってません。
-[[reimy]] &new{2003-07-18 (FRI) 01:04:21};
~Java ConsoleがONになってるのなら、OFF(「開始しない」)にしてみてください。このほうが起動も速くなりますし、負荷も少なくなるので。
-[[sha]] &new{2003-07-18 (FRI) 03:22:19};
~J2RE v1.4.2をインストールしてみましたが症状は変わりませんでした。Netscape 7.02(Java VM v1.4.2)でも試してみたところ、「ここをクリックしてPlug-Inを入手してください」と言われてしまいました。なぜ?
--[[reimy]] &new{2003-07-18 (FRI) 09:29:25};
~「コントロールパネル」→「Java-plugin」を起動して各ブラウザ用のプラグインをインストール
--[[sha]] &new{2003-07-18 (FRI) 12:00:28};
~Java-pluginを確認してみましたが、インストールされておりました。IEやNetscapeを見てもインストールされているように見えました。
-[[sha]] &new{2003-07-18 (FRI) 12:41:30};
~当初Windows XP Home Editionで#paintが動作しなかったのと同じバージョンのSunのJava(J2RE v1.4.0_03)を搭載している別のPC(Windows ME)では#paintが使えていることが確認できました(IE6.0でもNetscape 7.02でも)。一体何が違うのでしょうか?悩ましい。(OSが違うのが原因?)
-[[sha]] &new{2003-07-18 (FRI) 22:25:40};
~Windows MEでは、Netscape7.1, J2RE, SE v1.4.1_02で動作確認できました。OSの違いだけなんでしょうか?何となく、#paintやPCの設定では対処できない根本的なところが原因だというのが分かってきましたので、[[BBSPainter:http://tools.geocities.co.jp/SiliconValley-SanJose/8609/@geoboard/252.html]]の方へ対応をお願いしてみました。
-[[sha]] &new{2004-03-15 (MON) 13:29:42};
~結局BBSPainterのサイトでは対応はしてもらえませんでしたが、とおりすがりの方がアドバイスしてくれました。Windows XPでは、SunのJavaがうまくないようです。SunのJavaの代わりに、MicrosoftのJava(msjavx86.exe, 5,449,848 byte)を使うと大丈夫のようです。ただし、Microsoftからの配布は停止しておりますので、他から入手する必要があります。検索すると、いろいろ出てきますが、たとえば、http://dl.msg.yahoo.co.jp/dl/msvm/msjavx86.exe が利用できます。
動作させるには、インストール後に、インターネットオプションの詳細設定でJava(Sun)のチェックを外しておく必要があります。
-[[believe:]] &new{2004-04-22 (THU) 12:18:43};
~ローカル環境でのBBSPainterの動作はどうでしたか?私は、「ローカル環境では動作するのに、wiki上からだと、動作しません」でした。で、wikiのpluginフォルダの中にあるpaint.inc.phpの151行目あたり、「archive="BBSPainter.jar"」との記述を「archive="/BBSPainter.jar"」と書き換えたら、うまくいきました。(おそらく、ディレクトリ・ファイル・サーバ動作環境におけるファイル指定記述の違い?)回答になってるかわかりませんが。[[こんな:http://vf.tanigawa.jp/index.php?%3A%A5%C1%A5%A7%A5%B12FT%2F%BF%B7%B5%A1%C7%BD]]感じです
-私はローカル(bbspainter_120.lzhに添付されているindex.html)でIE,Mozillaがフリーズする現象がおきました。環境はWIN2000SP4,IE6SP1です。shaさんのおっしゃる通りMSのJava仮想マシンを使うと改善しました。 -- [[7eft]] &new{2004-09-15 (水) 20:40:04};
-bbsprinterのアーアカイブを解凍すると、bbsprinter.jarのようにすべて小文字だったのですが、BBSPrinter.jarとファイル名を直して設置しないとclassがロードされませんでした。あと、私も上記のMSのVMがないとハングしましたが、いれたら動作しました。 -- [[shida]] &new{2005-04-08 (金) 15:13:55};
- [[Q&Aに移動>Q&A/プラグイン#a8ba878e]] -- [[zm]] &new{2007-08-18 (土) 21:11:52};
- Clientの環境によって左右されてしまうのは痛いですね… -- [[Mike]] &new{2007-11-21 (水) 12:16:06};

#comment

トップ   編集 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Site admin: PukiWiki Development Team

PukiWiki 1.5.3+ © 2001-2020 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u12. HTML convert time: 0.042 sec.

OSDN