**[[続・質問箱/436]] [#j5dee406]
#author("2018-03-11T14:21:27+09:00;2009-05-06T17:15:25+09:00","","")
**[[質問箱/2436]] [#j5dee406]
|RIGHT:70|LEFT:410|c
|~カテゴリ||
|~サマリ|複数グループを作ると認証できなくなる|
|~バージョン|1.4.4|
|~投稿者|[[Dr.Doraemon]]|
|~状態|完了|
|~投稿日|&new{2004-11-12 (金) 22:32:16};|
***質問 [#b74ce7da]
pukiwiki.ini.phpにて、グループAとグループB以外からの閲覧、編集をできないようにするため下記のような設定をしました。

 $auth_users = array(
 	'group001' => 'aaaa-wwwww',
 	'group002' => '1234',
 );
 
 $auth_method_type = 'pagename';
 
 $read_auth = 1;
 
 $read_auth_pages = array(
 	'/.*/'  => 'group001',
 	'/.*/'  => 'group002',
 );
 
 $edit_auth = 1;
 
 // 編集認証対象パターン定義
 $edit_auth_pages = array(
 	'/.*/'  => 'group001',
 	'/.*/'  => 'group002',
 );
 
上記のよう設定をしたのですが、
一番目のグループAに関しては問題なく動作するのですが、グループ2の方はログインが出来ない状態になり、閲覧すら出来ません。

これは、どのようにすれば、よくなるのでしょうか?

phpのバージョンは、4.3.9になります。

ご指導の程、よろしくお願い致します。

***回答 [#ua2021d7]
-複数ユーザに対する*_auth_pagesの書式は
	'/.*/'  => 'group001,group002', 
オリジナルのpukiwiki.ini.phpを眺めれば分かる筈ですが… --  &new{2004-11-13 (土) 08:16:09};

//#comment

トップ   編集 差分 履歴 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Site admin: PukiWiki Development Team

PukiWiki 1.5.4+ © 2001-2022 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u12. HTML convert time: 0.045 sec.

OSDN