**[[質問箱3/43]] [#m44796b6]
#author("2018-03-11T15:14:17+09:00;2009-05-18T14:14:10+09:00","","")
**[[質問箱/3043]] [#m44796b6]
|RIGHT:70|LEFT:410|c
|~カテゴリ||
|~サマリ|[[[FAQ/22]]]lib/html.phpのエラー|
|~バージョン|1.4.5_1|
|~投稿者|[[つかさ]]|
|~状態|完了|
|~投稿日|&new{2005-04-29 (金) 22:15:26};|

***質問 [#add4dc6b]
ダウンロードしたファイルをアップしアクセスしたところ
Fatal error: Call to undefined function: version_compare() in /home/www/zaaxm000/public_html/ishimaru/lib/html.php on line 367
のようなエラーがでました。
ちなみに367行目のソースは
if (version_compare(PHP_VERSION, '4.3.0', '>=')) {
こんな感じでした。
ど素人なので全然わかりません。
サーバーのPHPのバージョンは
バージョン3.0.18-i18n-ja-3(CGI版) 
バージョン4.2.4(CGI版)
のように記載されています。
教えて下さいお願いします。

***前提 [#jf858693]
- PHPの関数 version_compare() は、PHP 4.1.0 以降に搭載されています。
-- http://jp2.php.net/manual/ja/function.version-compare.php

- version_compare() は、古いPHP向けに、PEAR パッケージの PHP_Compat に移植されているようです。
-- http://pear.php.net/package/PHP_Compat

***回答 [#ydf9af7c]
-バージョン4.2.4のほうを使うように設定されていますか? --  &new{2005-04-29 (金) 22:45:53};
-調べてみたらPHP Version 4.0.6みたいです。 -- [[つかさ]] &new{2005-04-30 (土) 11:54:39};
-http://licky.nu/phpinfo.php←参照 -- [[つかさ]] &new{2005-04-30 (土) 11:55:32};
-[[FAQ/22]] を見ると、PHPが4.0.6だと色々不都合が出そうな感じがしますね。 -- [[にぶんのに]] &new{2005-04-30 (土) 22:46:43};
-動作しないってことですかね〜? -- [[つかさ]] &new{2005-05-02 (月) 09:07:23};
-PHP4.0.6で動かすには根性が要るかもです (^^; CGI版PHP4.2.4が動くように設定できないか、探られてみてはいかがでしょう? -- [[teanan]] &new{2005-05-02 (月) 09:18:29};
-標準の状態では(上記のように)動作しなくなっているようです。version_compare()を使っている部分を環境にあわせて固定値に改造することでその先に進むとは思いますが、まだ他にも何かあるかもしれません。PHP4.1.2以降であればメンテナンスされているPHPも存在し(具体的にはDebian 3.0)ユーザーもそれなりにいるのですが、それより古いPHPをインターネット上で動かしている例がほとんどないせいか、それより古いPHPは注目されていません。管理者の方には、セキュリティアップデートの施された最新のPHPであるかどうかを問い合わせられた方が良いと思います。 -- [[henoheno]] &new{2005-05-02 (月) 20:03:27};
-問い合わせしたところPHPのアップデートはしてくれないとの事でした。設置できず残念です -- [[つかさ]] &new{2005-05-06 (金) 08:35:02};
-ということは、WebKeepersの[[サービス内容の記述:http://jp.webk.net/shared/service/database.html]]は間違いだったのでしょうか。 --  &new{2005-05-06 (金) 10:17:47};
--今までに挙げられたどの情報からWebKeepersに結びつくのでしょうか(確かにPHPのバージョンは上記の表記と同じようですが) -- [[henoheno]] &new{2005-05-06 (金) 13:58:39};
--licky.nuをwhoisで引くとDNSサーバがwebk.netだったのでそう思ってしまいました。違っていたらすみません。 --  &new{2005-05-06 (金) 16:14:03};
-- DNSサーバーのホスト先からの推測ですね。了解しました。とりあえずこちらにオフィシャルな動作例として phpinfo()  が晒されているようですが (^^; こちらも FreeBSD 4.3-REL の 4.0.6 のようですね。 http://support.webk.net/kbase/index.php?page=index_v2&id=384&c=1 -- [[henoheno]] &new{2005-05-06 (金) 23:06:53};

//#comment

トップ   編集 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Site admin: PukiWiki Development Team

PukiWiki 1.5.3+ © 2001-2020 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u12. HTML convert time: 0.049 sec.

OSDN