**[[質問箱3/154]] [#w2a526ec]
#author("2018-03-11T15:52:11+09:00;2009-05-06T18:48:25+09:00","","")
**[[質問箱/3154]] [#w2a526ec]
|RIGHT:70|LEFT:410|c
|~カテゴリ||
|~サマリ|EUC-JPではIE・Safariで独仏語特有文字名の入力・閲覧不可|
|~バージョン|1.4.5|
|~投稿者|[[witi]]|
|~状態|不明|
|~投稿日|&new{2005-07-25 (月) 10:45:22};|
***質問 [#r9d34c5d]
現在、バージョン1.4.5を利用しております。
charsetをEUC-JPにした場合、Firefoxでは、
ドイツ語のウムラウトやフランス語のアクサン等を含む
新規ページの作成・編集等、問題なくできるのですが、
IEでは新規作成時に入力が文字化けしてしまい不可能、
Safariの場合も入力は行えるが、
できたページは「????」となってしまいます。
仕様であれば、閲覧・編集するブラウザを制限せざるを得ません。
これらの点について、もし回避する方法がありましたら、
ご教授頂ければ幸いです。
よろしくお願いいたします。

***回答 [#lee055a3]
-EUC-JPだと表示できない文字だという可能性は無いですか?その場合、UTF-8化が有効な場合がありますが…。 -- [[Ratbeta]] &new{2005-07-25 (月) 11:57:04};
-なんと言ってもEUC-''JP''ですからね。多言語を扱うならUTF-8化をおすすめします。 --  &new{2005-07-25 (月) 20:31:58};
-もちろん、その通りなんですけどね。Firefoxでは編集・閲覧共にできるのが特殊なんでしょうか? -- [[witi]] &new{2005-07-25 (月) 20:49:26};
-العربية • فارسی • हिन्दी • ქართული • मराठी • संस्कृतम् • ไทย • Afrikaans • Asturianu • Bân-lâm-gú • Беларуская • Bosanski • Cymraeg • Ελληνικά • Simple English • Euskara • Frysk • Gaeilge • Gàidhlig • Galego • Hrvatski • Ido • Interlingua • Ирон æвзаг • Íslenska • Basa Jawi • Kurdî / كوردی • Latina • Latviešu • Lëtzebuergesch • Lietuvių • Македонски • Bahasa Melayu • Norsk (nynorsk) • Plattdüütsch • Shqip • Sicilianu • Tagalog • Tatarça • Türkçe • Tiếng Việt • Walon -- [[TaK@0hit]] &new{2005-07-25 (月) 22:43:08};
-私の環境にはSafariがなく多言語も扱いませんのでまともな意見かどうか分かりませんが・・・。[[SafariのバグによるPukiWikiへの影響]]あたりと関係があるのかな?上のコメントはWindowsXP IEを使いました。wikipediaのトップのコピペです。 -- [[TaK@0hit]] &new{2005-07-25 (月) 22:43:21};
-G穫sebl殞chen --  &new{2005-07-26 (火) 00:36:45};
-このサイトはUTF-8ですが、上記の書き込みのように、IEで書くと、コピペかどうか関係なく、やはり文字化けしてしまいます。ちなみに、Mac版IEからですが・・・。 -- [[witi]] &new{2005-07-26 (火) 00:48:40};
-IE7βでは、上記の文字は正常に表示されるようです。報告まで。 -- [[Ratbeta]] &new{2005-08-01 (月) 12:22:57};


***質問箱3/158より移行 [#p8b195e7]
3/154の質問をしたものです。
Firefox、Safari、InternetExplorerで、検証をしましたが、
ページ内でのドイツ語などの入力は、たとえば「aウムラウト」なども「ä」といったコードを用いることで、文字化けせずに閲覧できることが分かりました。
が、Firefox以外のブラウザで新規ページを作成する際に、ウムラウトの入ったタイトルを付けると文字化けしたページができるので、上記のようなコードを用いた名前を付けようとしたところ「有効なWikiNameではありません」という表示になり、ページの作成ができません。WikiNameには使えない文字・記号などもあるかと思いますが、そうすると、Firefoxで利用できる点が不可解です。どなたかヒントをいただけないでしょうか。。。よろしくお願いします。

***回答 [#k6bb006a]
-[[質問箱3/154]]と同じ原因である可能性があります。ページ名を入力して、ブラウザ側で送信する際にEUC-JPで送信するため、([[質問箱3/154]]と同様に)Firefox以外では送信するデータが化けてしまっているのだと思われます。 -- [[Ratbeta]] &new{2005-07-26 (火) 22:51:08};
-[[質問箱/3154]]と同じ原因である可能性があります。ページ名を入力して、ブラウザ側で送信する際にEUC-JPで送信するため、([[質問箱/3154]]と同様に)Firefox以外では送信するデータが化けてしまっているのだと思われます。 -- [[Ratbeta]] &new{2005-07-26 (火) 22:51:08};
-なるほど、やはりそうですか。ところで、挙動としては、Firefoxが正しいのでしょうか?IEなどが正しいのでしょうか? -- [[witi]] &new{2005-07-27 (水) 15:35:52};

#comment

トップ   編集 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Site admin: PukiWiki Development Team

PukiWiki 1.5.3+ © 2001-2020 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u11. HTML convert time: 0.041 sec.

OSDN