**[[質問箱4/536]] [#x32f5748]
#author("2018-03-11T20:53:32+09:00;2009-12-06T20:40:13+09:00","","")
**[[質問箱/4536]] [#x32f5748]
|RIGHT:70|LEFT:410|c
|~カテゴリ||
|~サマリ|php 5.3.x で非推奨になった関数が使用されています|
|~バージョン|1.4.7|
|~投稿者|[[upken]]|
|~状態|完了|
|~投稿日|&new{2009-12-05 (土) 15:12:45};|
***質問 [#na559fce]
http://www.php.net/manual/ja/migration53.deprecated.php
サマリの通りですが、ereg など今後動作しなくなる関数が使用されているため、修正したほうが良いのではないでしょうか。
ereg ⇒ mb_ereg (mb_ereg もなくなるかもしれれませんが・・・)

自作スキンも同様です。

***回答 [#nbde1401]
- PukiWiki 開発サイトですべき話もしますが・・・。とりあえず、今の1.4 系のパッケージはPHP4 (4.1.2 以降) & PHP5 サポートです。1.4.x のままでPHP5  & PHP 6 サポートに変更するという予定でもない限り、PHP 6 で削除される予定の関数を使っていてもあまり問題ではないと思われます。(そもそも、PHP 5.0.x の時点ですでに非推奨となっている使い方を、PHP 4 と共存するためにやむを得ずしていますし)&br;もちろん、CVS版の方は徐々に準備を進めて・・・・・いるハズ。(最近はコミットする余裕がないようですが) --  &new{2009-12-05 (土) 22:00:28};
- 迅速な回答ありがとうございます。陰ながら応援しております。頑張ってください。 -- [[upken]] &new{2009-12-06 (日) 20:39:25};

#comment

トップ   編集 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Site admin: PukiWiki Development Team

PukiWiki 1.5.3+ © 2001-2020 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u12. HTML convert time: 0.041 sec.

OSDN