#author("2017-02-05T20:55:49+09:00","","")
**[[質問箱5/245]] [#dd1f1516]
#author("2018-03-11T22:12:08+09:00;2017-02-05T20:55:49+09:00","","")
**[[質問箱/5245]] [#dd1f1516]
|RIGHT:70|LEFT:410|c
|~カテゴリ|動作環境|
|~サマリ|セッション継続時間の変更|
|~バージョン|1.5.1|
|~投稿者|[[ine]]|
|~状態|完了|
|~投稿日|&new{2016-12-05 (月) 20:19:57};|
***質問 [#hdacba03]
-PukiWikiのバージョン:
--1.5.1
-PukiWikiが稼働しているOS種類、バージョン:
--ubuntu server 16.04
-PukiWikiを稼働させているWEBサーバー種類、バージョン:
--apache 2.4.18
-PukiWikiが使用するPHPバージョン:
--PHP 7.0.8
-自分が行なった手順、使用したソフト
--[[PukiWiki/Authentication]]に基づく認証設定。
--Form認証, 非LDAP
-何を実現したいか
-- 認証ユーザのセッション維持時間の変更
-- デフォルトのセッション維持時間が不明ですが、
~ ID, パスワードの入力を求められる頻度を減らしたく、
~ セッション維持時間を1ヶ月程度にしたいと考えていいます。
~ 良い方法があればご教授ください。



***回答 [#x85a26e4]
- まだ実際に試していませんが、.user.ini で session.cookie_lifetime を変えてみてはどうでしょうか? -- [[bee]] &new{2016-12-06 (火) 15:41:37};
- 大分期間が空きましたが、無事設定できたので設定内容を共有します。 -- [[ine]] &new{2017-02-04 (土) 23:57:07};
+ /etc/apache2/apache2.confの設定を変更
-- 変更前
 <Directory /var/www/>
 	Options Indexes FollowSymLinks
 	AllowOverride None
 	Require all granted
 </Directory>
-- 変更後
 <Directory /var/www/>
 	Options Indexes FollowSymLinks
 	AllowOverride All
 	Require all granted
 </Directory>
+ サーバセッションの設定を変更
-- /var/www/html/.htaccess
 <IfModule mod_php7.c>
     php_value session.save_path "/var/lib/php/sessions_wiki/"
     php_value session.cookie_lifetime 2678400
     php_value session.gc_probability 1
     php_value session.gc_divisor     1
     php_value session.gc_maxlifetime 2678400
 </IfModule>
+sessions格納ディレクトリを作成
 sudo mkdir /var/lib/php/sessions_wiki
 sudo chmod 733 /var/lib/php/sessions_wiki/
+ apache2を再起動
 sudo service apache2 restart
+ パラメータが設定されていることをphpinfoで確認
- 情報共有をありがとうございます。AllowOverride All は与える権限が強すぎますが、これを最小限にする場合 AllowOverride Options となるようですね。 -- [[henoheno]] &new{2017-02-05 (日) 20:55:49};

#comment

トップ   編集 差分 履歴 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Site admin: PukiWiki Development Team

PukiWiki 1.5.4+ © 2001-2022 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u12. HTML convert time: 0.066 sec.

OSDN