#author("2021-05-10T13:14:49+09:00","","")
#author("2021-05-10T13:38:29+09:00","","")
**[[質問箱/5406]] [#f0933115]
|RIGHT:70|LEFT:410|c
|~カテゴリ|その他|
|~サマリ|プラグインについての質問|
|~バージョン|1.5.3|
|~投稿者|[[タケダ]]|
|~状態|完了|
|~投稿日|&new{2021-04-19 (月) 11:52:42};|
***質問 [#s5bb346d]
/pukiwiki.sonots.com/
こちらのサイトで紹介されているtag,taglistプラグインを使おうと思っていたのですが、プラグインを呼び出そうとするとHTTPエラー500が出てきて動作しなくなってしまいます。
これはこのプラグインは1.5.3に対応していないということでいいのでしょうか?

***回答 [#me652ab8]
- 対応していません -- [[匿名]] &new{2021-04-19 (月) 12:48:33};
- PHPのバージョンはいくつでしょうか? 1.5.3 に対応していない可能性もありますが、プラグインがPHPの新バージョンに対応していない可能性もあります。[[Q&A/インストール#x80b2883]] 等を参照してエラー個所を特定して自力で修正するか、プラグイン作者に連絡して対応してもらうのが良いと思います -- [[umorigu]] &new{2021-04-19 (月) 22:31:17};
- 迅速な回答ありがとうございました!作者様はもう更新をやめてるみたいなので自力で何とかしてみようと思います。 -- [[タケダ]] &new{2021-04-21 (水) 09:26:41};
- ちょっと検索をかけたら1.5.3+PHP7.3でtagプラグイン及びtaglistプラグインが動いているらしいPukiWikiが見つかりますね。&br;他の自作プラグインとぶつかっているとか呼び出す場所が間違っている可能性もあるんじゃないでしょうか&br;[[質問箱/4547]] [[欲しいプラグイン/390]] -- [[D]] &new{2021-04-22 (木) 19:26:49};
- うちのPukiwikiでは、1.5.3とPHP7.4でtagとtaglistが使えています。 -- [[m0370]] &new{2021-04-23 (金) 08:27:17};
- taglist.inc.phpの167行目ga -- [[タケダ]] &new{2021-05-10 (月) 13:14:49};
- taglist.inc.phpの167行目の引数に「$unknowns, $conf_options」が抜けていたのとtag.inc.phpの行数は忘れてしまってたのですが「$」が付いていなくて変数になっていない箇所を直したら動作するようになりました。 -- [[タケダ]] &new{2021-05-10 (月) 13:14:49};

#comment

トップ   編集 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Site admin: PukiWiki Development Team

PukiWiki 1.5.3+ © 2001-2020 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u12. HTML convert time: 0.090 sec.

OSDN