calendar プラグインにXSS脆弱性

  • ページ: BugTrack
  • 投稿者: masao
  • 優先順位: 緊急
  • 状態: 完了
  • カテゴリー: 本体バグ
  • 投稿日: 2003-02-28 (金) 07:34:13
  • バージョン:

メッセージ

なんだかプラグイン周りは大量に残ってそうな予感がしてますが、一応報告しておきます。

例:

#calendar(<script>alert('hello')</script>)
#calendar(<script>alert('hello')</script>)

  • cvsに投入しました。cvs:calendar.inc.php(v1.4:r1.13)(v1.3.3:r1.10.2.1) -- ぱんだ 2003-02-28 (金) 12:16:58
  • このページを表示するとエラーが出ますね。Parse error: parse error in /var/autofs/misc/groups/p/pu/pukiwiki/htdocs/dev/plugin/calendar.inc.php on line 41 -- reimy 2003-02-28 (金) 22:32:04
    • すいませんm(__)mコミットの直前にセミコロンを一個消してしまってました。 cvs:calendar.inc.php(v1.4:r1.14)で修正しました。 -- ぱんだ 2003-02-28 (金) 23:26:44

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2003-02-28 (金) 23:46:29
Site admin: PukiWiki Development Team

PukiWiki 1.5.2+ © 2001-2019 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u7. HTML convert time: 0.175 sec.

OSDN