PHP 5.3 でエラーが出るようになった

PHP5関連

メッセージ

これまでのバージョンでは特に問題がなかったのですが、PHP 5.3 にするといくつかエラーが出てくるようになりました。

  1. date 関数などで、Warning が発生する
    • 今まではWarning が出なかったのですが、PHP 5.3 にしたとたん出るようになりました。date.timezone のphp.ini 設定かdate_default_timezone_set 関数を使えと言ってきますが、これらはPHP 5.1.0 以降でないと使えないので、サポート対象のPHP を変えないのであればエラー抑制するしかないと思います。(デフォルトがerror_reporting(E_ERROR | E_PARSE); なんで、必要がないのかもしれませんが・・・)
  2. tracker_list プラグインのソートが機能しない
    • official:質問箱4/480 で少し話が挙がっていますが、array_multisort 関数でWarning が発生します。
      Warning: Parameter 1 to array_multisort() expected to be a reference
      error_reporting(0); にしてエラー出力をOFF にすると表示はできるんですが、ソートが機能してくれません。

とりあえず、今気がついているのはこれだけです。

新設されたE_DEPRECATED レベルはE_STRICT レベルと同様に出力しないようにしないと、PHP 4 でも動作するように書かれている部分でエラーが出てしまう*1ので、あえて記述してません。



*1 & 演算子を使ってクラスを呼び出す所が、E_DEPRECATED レベルのエラーになってました

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2016-01-11 (月) 22:46:51
Site admin: PukiWiki Development Team

PukiWiki 1.5.3+ © 2001-2020 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u12. HTML convert time: 0.225 sec.

OSDN