PukiWikiサポート対象外のPHPならば、エラーを表示し強制終了してはどうか

メッセージ

BugTrack/2388より分割)

version_compare 関数でPHPのバージョンチェックを行い要件をみたしていないPHPは、エラーを表示し強制終了するように変更する

if (version_compare(PHP_VERSION, '5.3.0') < 0)
   exit('ERROR: Installed PHP version is too old. Please check the oparation requirement.');

これにより要件を確認していない人との無駄なやりとりがなくなる。

事例




トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2017-02-17 (金) 23:15:23
Site admin: PukiWiki Development Team

PukiWiki 1.5.3+ © 2001-2020 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u12. HTML convert time: 0.150 sec.

OSDN