Category: :Internationalization

多言語対応関連 (使用言語の設定)

メッセージ

現行のPukiWikiでは、言語関連の設定をすべてinit.phpで行っていますが、
これをpukiwiki.ini.phpと*.lngに分ける必要があると思います。

修正案 : (長いのでコメントアウトしておきました)


第二段階 : 言語ファイルに不足がある場合はen.lngで補填する

第三段階 : encode_hintとUTF-8関連

余談 : 言語ファイルと複数Wiki


*1 このあたりは、PHPに限らず Perl や Python など、どの言語も苦しんでいるようです。

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2005-02-25 (金) 23:30:19
Site admin: PukiWiki Development Team

PukiWiki 1.5.3+ © 2001-2020 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u12. HTML convert time: 0.947 sec.

OSDN