LANG=enでコンバート系プラグインが動作しない(MenuBar含む)

  • ページ: BugTrack
  • 投稿者: henoheno
  • 優先順位: 重要
  • 状態: 完了
  • カテゴリー: 本体バグ
  • 投稿日: 2005-02-05 (土) 15:40:59
  • バージョン: 1.4.5_alpha - 1.4.5

修正

関連

メッセージ

英語環境のために LANGを en にした場合、コンバート系のプラグインが全て動作しなくなります。


--- plugin.php  30 Dec 2004 13:50:54 -0000      1.6
+++ plugin.php  5 Feb 2005 06:43:23 -0000
@@ -110,10 +110,12 @@
        } else if (PKWK_ENCODING_HINT != '') {
                // Insert a hidden field, supports idenrtifying text enconding
                return preg_replace('/(<form[^>]*>)/', '$1 ' . "\n" .
                        '<div><input type="hidden" name="encode_hint" value="' .
                        PKWK_ENCODING_HINT . '" /></div>', $retvar);
+       } else {
+               return $retvar;
        }
 }

  • cvs:lib/plugin.php (1.7)
  • if文の末尾から else がなくなっていました (^^; -- henoheno 2005-02-05 (土) 15:49:12
    • LANG=ja の場合 PKWK_ENDOCING_HINT に値が入りますのでここでひっかかりませんが、LANG=en にした場合は PKWK_ENCODING_HINT が空文字列になるため、ここでひっかかるということの様でした。 -- henoheno 2005-02-05 (土) 16:27:49

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2005-02-05 (土) 16:27:49
Site admin: PukiWiki Development Team

PukiWiki 1.5.2+ © 2001-2019 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u7. HTML convert time: 0.145 sec.

OSDN