PukiWikiプラグインをPHP7やPHP8で動かすための情報を集めるページです。

背景

このプロジェクトとして行うこと

PHP8で動作するプラグイン情報

プラグインリンクオリジナル作者ライセンスPHP8 対応者対応日備考
sofficial:Plugins/s.inc.phpumoriguGPLumorigu2021-12-022.0betaで対応
tagofficial:Plugins/tag.inc.phpsonotsGPLはいふん2021-12-14
includexofficial:Plugins/includex.inc.phpsonotsGPLはいふん2021-12-14
contentsxofficial:Plugins/contentsx.inc.phpsonotsGPLはいふん2021-12-14
lsxofficial:Plugins/lsx.inc.phpsonotsGPLはいふん2021-12-14
markdownofficial:Plugins/markdown.inc.phpsonotsGPLはいふん2021-12-14
egexpofficial:Plugins/regexp.inc.phpsonotsGPLはいふん2021-12-14
replacepluginofficial:Plugins/replaceplugin.inc.phpsonotsGPLはいふん2021-12-14
votexofficial:Plugins/votex.inc.phpsonotsGPLはいふん2021-12-14
codehighlightofficial:Plugins/codehighlight.inc.phpskyGPLはいふん2021-12-17
tvoteofficial:Plugins/tvote.inc.phptokiwaGPLはいふん2021-12-17

※ライセンスの"GPL" は GPLv2, GPLv3, 「PukiWikiと同じ」等を含む。詳細は各プラグインのページを参照してください。

参照

コメント

最新の30件を表示しています。 コメントページを参照

  • PHP8でプラグイン互換性がより問題になることが分かったのでBugTrack/2471を受けて、プラグインをPHP8対応にする情報を集めるページを作りました -- umorigu 2021-11-28 (日) 15:53:35
  • ここにはPHP8で動かなくなったプラグインを書けば良いのでしょうか?SonotsさんのPukiWikiプラグインはほぼ動かなくなっています(pukiwiki.sonots.com)。classを多用しているものがPHP 8未対応のようです。 -- - 2021-11-29 (月) 17:42:05
    • classのコンストラクタで問題があるプラグインはclassと同じ名前の関数(コンストラクタ)を"__construct"へ修正すると動作する可能性があります。 -- はいふん 2021-11-29 (月) 22:33:00

例えばtag.inc.phpの場合はクラスが3箇所(PluginTag, Tag, TagCloud)あります。

class PluginTag extends Tag
{
    function PluginTag()
    {
        (省略)
    }
    (省略)
}

上記のソースにある"function PluginTag()"を下記のソースのように"function __construct()"と変更します。

class PluginTag extends Tag
{
    function __construct()
    {
        (省略)
    }
    (省略)
}
  • はいふんさん、ありがとうございます。素晴らしいです!できればなのですが、OSDN.jpの PersonalForgeGitHub のような、変更がトレースできて、個人が放っておいても維持される可能性の高い場所での公開をお願いできないでしょうか?これらの場所ならInterWikiでリンクもはれます。私も少し使っています。 osdn.net:users/umorigu/pf/pukiwiki15 -- umorigu 2021-12-15 (水) 21:48:54
  • ありがとうございます!早速使ってみました。 -- はいふん 2021-12-15 (水) 22:46:19
  • 仕事がはやい! ありがとうございます -- umorigu 2021-12-15 (水) 22:59:30
  • official:自作プラグイン/1のattachrefプラグインを修正したところ、コメントアウトが以下のようにミスっていました。PHP8からはこの構文のミスはエラーとなり見逃してくれないようです。 -- はいふん 2021-12-11 (土) 11:11:51
    $//args = split(",", $vars['attachref_opt']);
    • これはなんというかこれまで動いていたのが不思議ですね -- umorigu 2021-12-11 (土) 13:11:49
  • Officialの方にも official:Project-8 を作りました。どちらに何を書くかが難しい。全部devでもよさそうですが・・ -- umorigu 2021-12-15 (水) 22:35:48
  • official:自作プラグイン/codehighlight.inc.php, official:自作プラグイン/tvote.inc.php
    こちらのプラグインもphp8に対応させてみました。tvoteについてはcreate_function()が廃止された影響で使えなくなってたみたいですね -- はいふん 2021-12-17 (金) 22:22:46
  • s.inc.php も更新していたのでコメントしておきます -- umorigu 2022-01-23 (日) 15:28:32
  • これまで集まったプラグインの情報を「PHP8で動作するプラグイン情報」 Project-8#workon8 として表にしました。 -- umorigu 2022-01-23 (日) 15:30:18
お名前:

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2022-01-23 (日) 15:35:17
Site admin: PukiWiki Development Team

PukiWiki 1.5.4+ © 2001-2021 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u12. HTML convert time: 0.885 sec.

OSDN