エディタの最低要件

  • 文字コードを破壊しないこと

エディタのあると得する要件

  • デバッガ対応だと実行しながらバグを追うことができる
  • バージョン管理対応だと開発版を簡単に追うことができる

目次

推奨エディタ一覧

名称OSコード支援定義へジャンプデバッグバージョン管理その他値段URL
NetBeansAll+JAVAFreehttp://netbeans.org/
EclipseAll+JAVAFreehttp://www.eclipse.org/
Zend StudioLinux,Windows,Mac$299
RadPHP XEWindowsUTF83万円前後

非推奨エディタ一覧

Windows(非推奨エディタ)

  • Windows メモ帳
    • SJISに特化。UTF8の場合は、UTF8ヘッダを挿入するので使用禁止。
  • PHPエディタ(phpspot)
    • UTF8領域のコードに対応していない
      • Windows98/Meがサポート対象に入っているため、ソフトの内部動作をUnicodeにしてビルドしていないのが原因?
      • ソフト内部ではSJISコードなので SJIS外のUTF8コードは?(0x3f)に変換され破壊される
      • ソフト内部ではSJISコードなので ウムラウトなどが破壊される。(例:ö→o)
      • UTF8と表示されていても読み込み時にSJISに・保存時にUTF8に変換しているだけである。あくまでも内部はSJISコード。なので、UTF8領域のコードが必要な場合は絶対に使ってはいけない。
    • 文字コードの自動判別の判定が甘い。
      • UTF-8よりもShift-JISやEUC-JPの検出順位が先のため、ASCIIコードのような同一に見える部分しか含まれていない場合はそちらが優先されてしまいます)
    • 文法解釈が間違っているので、関数名が左の一覧に表示されないことがある。
    • 特定の構文を書くとフリーズする

文字コードの設定

  • NetBeans プロジェクトプロパティ
  • Eclipse
    • EUC-JPの場合は手動で設定を変更する必要あり(デフォルトはUTF-8)

関連


トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2010-12-09 (木) 16:05:34
Site admin: PukiWiki Development Team

PukiWiki 1.5.2+ © 2001-2019 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u7. HTML convert time: 0.181 sec.

OSDN