#author("2016-10-15T14:40:32+09:00","","")
RIGHT:&size(12){Category:[[Design>:Design]], [[CSS]]};
* スマートフォン対応 [#kdb7f613]

- ページ: [[BugTrack2]]
- 投稿者: [[umorigu]]
- 優先順位: 普通
- 状態: 提案
- カテゴリー: 本体新機能
- 投稿日: 2016-05-17 (火) 01:22:50
- バージョン: 1.5.1

** メッセージ [#v07f8bbd]
標準スキンをスマートフォン対応にしたい。スマートフォンの画面サイズに最適化して表示する。



--------
- [[official:PukiWiki/Download/1.5.1]] での要望を転記しました -- [[umorigu]] &new{2016-05-17 (火) 01:25:45};
- Twitter bootstrap等を使えると楽なのですが、標準でできるだけ外部ライブラリに依らない作りにしたいと思っていて、そこが悩みどころです -- [[umorigu]] &new{2016-05-17 (火) 01:23:47};
- ぜひお願いする -- [[匿名]] &new{2016-05-18 (水) 00:14:59};
- [[dev:BugTrack2/368]]これも考えて欲しいです -- [[.>./]] &new{2016-06-15 (水) 01:43:40};
- $pkwk_dtd に PKWK_DTD_HTML_5 を足したくなりますね。あるいは $pkwk_dtd 周辺のロジックをすべて削除して <!DOCTYPE html> に統一してしまうか。 -- [[bee]] &new{2016-09-28 (水) 20:36:40};
- HTML 4 互換なkeitaiスキンの存続問題や、convert_html やmake_link などの改修話(HTML 5 のタグや属性を入れるかどうかや、[[BugTrack2/388]]ネタなど)にまで、いづれは発展しそうですねソレ>DTD切り替え [[BugTrack/768#reea7092]] --  &new{2016-09-30 (金) 20:38:14};
- 半ば自己レスになりますが、HTML5 は DTD で定義されているわけではないので PKWK_DOCTYPE_HTML5 のほうがいいのかもしれない。あと $pkwk_dtd も $pkwk_doctype にしようとか、PKWK_DOCTYPE_XHTML5 が必要かどうかとか… -- [[bee]] &new{2016-10-01 (土) 20:31:41};
- そうですね。DocTypeはもうHTML5のものでいいと思ってます。古いブラウザは無視してくれるでしょうし -- [[umorigu]] &new{2016-10-07 (金) 23:50:29};
- [[BugTrack2/389]] HTML5 の DOCTYPE 宣言を出力できるようにする --  &new{2016-10-15 (土) 14:40:32};

#comment

トップ   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Site admin: PukiWiki Development Team

PukiWiki 1.5.3+ © 2001-2020 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u12. HTML convert time: 0.133 sec.

OSDN