* plugin.php rewrite [#r6169318]

- ページ: [[BugTrack2]]
- 投稿者: [[JordanC]]
- 優先順位: 低
- 状態: 却下
- カテゴリー: その他
- 投稿日: 2008-03-25 (火) 21:43:51
- バージョン: 0.2.0


** メッセージ [#i981a123]
Plugin.php was pretty damn messy (quite a few of the lib stuff is) so i've rewritten all of it. I'll be going through all /lib/ and rewriting so that it's at least not as literal as it was.

Sources: http://sourceforge.jp/tracker/index.php?func=detail&aid=12174&group_id=166&atid=713

*** Please descrive what is/are the point(s) [#j4e1a1c9]
- plugin_callback_exists() と plugin_do_callback()にまとめちゃいました、って感じですね :) --  &new{2008-03-26 (水) 20:21:17};
-- If you check the old version of the file, you have 3 functions when the operation required is one and the same. They were to validate the "action" and various other parameters. plugin_callback_exists checks for the existance of the specified plugin_<func>_<x> function in the plugin, and the plugin_do_callback function is a generic function from my PHP framework which runs multi-parameter and linear-parameter callbacks. -- [[JordanC]] &new{2008-03-30 (日) 03:24:47};


** Comments for the license [#uc2ea27d]
- Please quote the licence of the code at the head of it. Most part of PukiWiki are "GPL v2 or (at your option) any later version" --  &new{2008-03-25 (火) 23:03:37};
-- I've already quoted the license correctly at the top of the file, For the other parts of the file that were in there, they were also GPLv2, so I'll just expand the contributor list to include them. Problems can arise from moving from GPLv2 to GPLv3, specifically because if it was implicitly defined by the previous auther they may not want the more expansive license to cover their code. Just a thought. -- [[JordanC]] &new{2008-03-26 (水) 01:23:16};
-- Author* -- [[JordanC]] &new{2008-03-26 (水) 01:23:34};
-- Regardless, it's been updated. :) -- [[JordanC]] &new{2008-03-26 (水) 01:28:35};

- relation: [[BugTrack2/61]] --  &new{2008-03-30 (日) 23:37:52};
- Hi, thanks for your cooperation. First I don't understand why the code says only GPL2. But now I undestand by finding your PukiWiki-site's footer (says the same, GPL2 only). %%May we misunderstand you?%% Probably we misunderstood you?  (Fixed => [[cvs:COPYING.txt]] (r1.2)) -- [[henoheno]] &new{2008-03-30 (日) 23:43:43};


** Investigation: slightly hard to review [#a233f654]
- Hmm... I'm still suffering why so many (NOT ONE) claims are survived in this ONE proposal. If you get the style of some sort of communication via source or someting, your proposal must be more precious. -- [[henoheno]] &new{2008-07-14 (月) 23:58:22};
-- Reference: "2289: plugin.php"
-- Line 1: $Id (1.15) shows me you get the source from the stable version. Yes you can post this using 1.15, but this style clearly says: "This is just an idea. I don't consider HEAD version to be mergerd". If you truly want to pass your idea to us smoothly, you must choose the HEAD (in this time, 1.19). ((開発版を対象にしたパッチを下さい。優れたアイデアなら、stableを対象にしても構いませんが、丸ごとよこした場合はもちろん伝わり辛くなります))  -- [[henoheno]] &new{2008-07-15 (火) 00:06:51};
-- Line 5: You should not add "apparently" here. These are just garbages for diff. -- [[henoheno]] &new{2008-07-15 (火) 00:14:44};
-- Line 9-27: You should say another proposal in the another proposal. -- [[henoheno]] &new{2008-07-15 (火) 00:18:43};
-- Line 30: Then, why ''we''(me and, others), must use ''diff'' from 1.15 to ''separate'' our work and ''your work'' in these situation, by hand? If it can be clear beforehand, it should be by yourself. And, please note that "I rewire it. Read this" style (with garbages) hunts, a lot of reviewer's time. -- [[henoheno]] &new{2008-07-15 (火) 00:20:53};
-- (To be continued: All comments above are just self-questions when I see the style) -- [[henoheno]] &new{2008-07-15 (火) 00:21:53};
- I'll respond to this. Firstly, this was more of a proof of concept, but I've done a few things the wrong way and I apologise; I didn't follow the process for proposals and I didn't pull from the HEAD. I dislike CVS as it is incredibly shit, and I really dislike using it in the first place - the idea of this code was simply to give an example of the functions for plugins being consolidated into one handler, and then simply passed to it rather than to 3 separate functions. Modularity is lost if functions have to be implicitly used to handle so-called "plugin" functionality.

If you want me to rewrite this then I'll be more than happy to make even better code. As for the proposals - most of the pages for proposals are old, and when I first came here I literally thought it was a dead project. If you give me a page for proposals other than where I have already posted (check my page) then I will gladly outline very clearly what changes I'd like to make. Apologies for any issues we've had in the past. Kindest regards, [[JordanC]]
- Next version? => [[BugTrack2/314]] -- [[henoheno]] &new{2008-07-16 (水) 01:21:18};
- I started investigating your comments from [[BugTrack/785]], because this page was at the top at the time, and seemed easy to clear the problem. Next I decided to investigate this (BugTrack2/301), the oldest one, because I make you wait so long. Your experience and idea must be useful for us, but less-experiences as a PukiWiki user (Not as a CMS but as a Wiki), and far from design/concept/history about the product, may become a bottleneck for now. But if you kept KISS theory, it goes smaller I think.-- [[henoheno]] &new{2008-07-16 (水) 01:24:23};


** Comments [#r4ea42ad]
- Can't attach the file to this bug report - how would you like me to create it? -- [[JordanC]] &new{2008-03-25 (火) 21:48:52};
-- How about: http&#x3a;//sourceforge.jp/tracker/index.php?func=detail&aid=12174&group_id=166&atid=713 --  &new{2008-03-25 (火) 22:18:31};
-- Can't attach the file to this bug report - how would you like me to create it? -- [[JordanC]] &new{2008-03-25 (火) 22:21:58};
-- How about creating a page and paste the source. &br; For example, [[./source]]. -- [[ぃぉぃぉ]] &new{2008-03-25 (火) 22:32:21};
-- If you check the SF page, I've added the source there for you. It's also been documented with PHPdocumentor, and other info is on the post. -- [[JordanC]] &new{2008-03-25 (火) 23:03:25};
--- http&#x3a;//sourceforge.jp/tracker/index.php?func=detail&aid=12174&group_id=166&atid=713

- Sorry, but what is mariburjeka?Jane. -- [[sweet-we]] &new{2008-03-26 (水) 08:20:36};
-- kimerikas? -- [[JordanC]] &new{2008-03-26 (水) 19:27:51};
- Please move this article back into BugTrack2 --  &new{2008-03-26 (水) 20:31:08};
-- And, please create a diff file, too. --  &new{2008-03-26 (水) 20:31:44};
-- I hate to be negative, but I have a pathological dislike for CVS, and sourceforge makes that increase in magnitude. Can someone please diff it for me? -- [[JordanC]] &new{2008-03-26 (水) 23:24:12};
-- [[./source]] --  &new{2008-03-28 (金) 00:55:49};
- What is the obsession with defining variables in code with nested if's when my code is rewritten? It means that then, php has to parse more logical structures in order to return a singular output!  -- [[JordanC]] &new{2008-03-30 (日) 03:27:29};
-- That, and it looks shitty :P -- [[JordanC]] &new{2008-03-30 (日) 03:31:35};
- relation: [[BugTrack/149]] --  &new{2008-03-30 (日) 23:37:52};
- [[This file>http&#x3a;//sourceforge.jp/tracker/download.php?group_id=166&atid=713&file_id=2259&aid=12174]] has some error codes with using error_reporting(E_ALL). --  &new{2008-04-17 (木) 01:58:09};
 Parse error: syntax error, unexpected '{' in /pukiwiki/lib/plugin.php on line 97
 Parse error: syntax error, unexpected ';' in /pukiwiki/lib/plugin.php on line 98
 Parse error: syntax error, unexpected T_ELSEIF in /pukiwiki/lib/plugin.php on line 166
 Fatal error: Call to undefined function do_plugin_init() in /pukiwiki/lib/plugin.php on line 113
- Apologies, the file was written in KATE (http&#x3a;//kate.kde.org/ ) which doesn't have tie-ins with the php binary. I'll fix the errors :) -- [[JordanC]] &new{2008-04-24 (木) 02:31:39};
- I moved 'plugin.php' files from OSDN ticket system to this page. Let's close the ticket. -- [[umorigu]] &new{2017-02-22 (水) 22:08:24};
- I moved 'plugin.php' files from OSDN ticket system to this page. Let's close that ticket. -- [[umorigu]] &new{2017-02-22 (水) 22:08:24};
-- From: https://osdn.net/ticket/browse.php?group_id=166&tid=12174
 Just a quick note -- will not work with the rest of the
 functions as these are used outside of the scope of
 this file. I am rewriting the remainder of /lib/ so
 that this is possible.
 Also, you need to have a naming convention. If you've
 got the file "plugin.php" then the good function
 declarations are usually "plugin_" rather than 
-- plugin.php.fileid_2256.php (File ID: 2256, Uploaded: 2018-03-25 22:38)
--- https://osdn.net/ticket/download.php?group_id=166&tid=12174&file_id=2256
-- plugin.php.fileid_2259.php (File ID: 2259, Uploaded: 2018-03-26 01:28)
--- https://osdn.net/ticket/download.php?group_id=166&tid=12174&file_id=2259
-- plugin.php.fileid_2289.php (File ID: 2289, Uploaded: 2018-04-24 02:41)
--- https://osdn.net/ticket/download.php?group_id=166&tid=12174&file_id=2289


トップ   編集 差分 履歴 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Site admin: PukiWiki Development Team

PukiWiki 1.5.4+ © 2001-2022 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u12. HTML convert time: 0.042 sec.