*ブロック内で使用できる水平線プラグインを [#vf7f7f4b]

-ページ: BugTrack
-投稿者: [[reimy]]
-優先順位: 普通
-状態: 完了
-カテゴリー: プラグイン
-投稿日: 2003-06-23 (月) 16:01:12
-バージョン: 

**メッセージ [#n022821b]
水平線(----)はブロック要素内で使用できず、ブロックから脱出してしまうため、ブロック内で水平線が引けない。

hr.inc.phpを自作して対応していたが、PukiWiki-officialでは正式版でないと使っちゃいけないそうなので。

なお、水平線(----)はページの上下の水平線としても使用されているため、事実上、幅が100%に固定されてしまうが、ブロック要素(p,ul,ol,dl,tableなど)の左右にmarginが設定されている場合、----を使用すると幅が100%であるためバランスが悪くなる。

ブロック要素内で使用できる水平線プラグインであれば、ページの上下の水平線とは独立しているので自由に設定できる。

 <?php
 // $Id: hr.inc.php,v 1.1 2003/02/28 02:42:57 reimy Exp $
 
 function plugin_hr_convert()
 {
 	return "<hr class=\"hr_short_line\" />";
 }
 ?>
----
-気持ちも分かりますが、誰にお願いしているのでしょうか?ということを冷静に考えてみてください。そして、正式版で欲しいのであれば、その自作の hr.inc.php が正式版じゃ駄目なのですか?と思います。そうでないと、バグ潰しとか色々とある上に、hr.inc.php も開発するのですか?せっかくあるのに、もったいないなぁ。と思います。管理者も大変かと思いますが、頑張って下さい。ちゃんと応援しますからね。 -- [[upk]] &new{2003-06-23 (月) 21:28:07};
->その自作の hr.inc.php が正式版じゃ駄目なのですか?&br;ということなので、PukiWiki-officialで使っても良いそうです :p  --  &new{2003-06-23 (月) 23:11:48};

#comment
//#comment

トップ   編集 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Site admin: PukiWiki Development Team

PukiWiki 1.5.3+ © 2001-2020 PukiWiki Development Team. Powered by PHP 5.6.40-0+deb8u12. HTML convert time: 0.060 sec.

OSDN